Basa Basi Routing Jaringan

Inget masa muda dulu waktu masih aktif di ARC. Liat orang make layar item tapi gak pernah beranjak dari tempat duduknya, jadi bikin penasaran. Ngoprek anak ARC waktu jaman dulu tu bisa dibilang kejam. Ada laler di hidungnya keknya gak bakal di usir. Ilmu tentang jaringan yang didapat dari ngoprek sama anak ARC cuma dikit dan hasilnya cuma jadi orang sok tau.  Kitab jaringan anak ARC ada 2 , yaitu: buku TCP/IP nya pak onno dan temen temen sama buku dari Routing TCP/IP karyanya Jeff Doyle, CCIE& Jennifer Dehaven Carroll, CCIE.  Sampai sekarang saya masih membawa buku volume II yang nyolong dari arc ^_^, walaupun masih kagak ngerti ngerti.  Nyoba ngringkes routing jaringan walau agak sok tau, tapi gak pa palah biar ngisi blog lagi setelah vakum cleaner selama hampir setahun heuheuheu.

Routing Static
bajaklaut(config)#ip route destination-prefix Destination-prefix-mask Forwarding-router’s-address
Misal router bajaklaut ingin berkomunikasi dengan router loro berada di network 167.205.49.0 yang terhubung dengan router siji dengan network 167205.37.0 terhubung ke bajaklaut.
Loro-siji-bajaklaut
Bajalaut(config)#ip route 167.205.49.0 255.255.255.0 167.205.37.1
Paket dari router bajaklaut yang akan menuju ke network 167.205.49.0 akan dikirim oleh 167.205.37.1

Jika di freebsd
#Route add default 167.205.37.1
#Route add -net 167.205.49.0 -netmask 255.255.255.0 167.205.37.1

RIP
Berdasarkan vektor jarak, interior gateway protocol (IGP) dimana digunakan untuk saling berukar routing informasi. Rip menggunakan perhitungan hop untuk menentukan jalur yang tepat antara dua lokasi. Jumlah hop adalah jumlah paket yang melewati router untuk mencapai network tujuan. Jumlah maksimum hop dari paket yang melintasi suatu network adalah 15 hop.
Pada rip network, tiap tiap router membroadcast tabel rip ke router tetangganya setiap 30detik. Ketika router menerima rip tabel dari tetangganya, informasi tersebut digunakan untuk mengupdate routing tabelnya sendiri dan mengirim update tabel tersebut ke tetangganya. Prosedur tersebut berulang di tiap tiap router dan hasilnya semua router mempunyai internetwork topology.

Bajaklaut(config)#router rip

Karena rip adalah bersifat classful, hanya bagian kelas dari alamat harus ditetapkan pada network.
Misal router bajaklaut mempunyai dua interface yang terhubung di dua network
Bajaklaut(config-router)#network 167.205.37.0
Bajaklaut(config-router)#network 167.205.3.0
Bajaklaut#show ip route

IGRP (Interior Gateway Routing Protocol)
Menggunakan vektor jarak untuk bertukar informasi routing, composite metric of bandwidth dan delay untuk menentukan jalur yang tepat diantara dua lokasi. Pada jaringan IGRP, tiap tiap router membroadcast seluruh tabel IGRP ke router tetangganya setiap 90 detik. Ketika router menerima tabel IGRP dari tetangganya, informasi tersebut digunakan untuk mengupdate tabel routing dan mengirim update tersebut ke router tetangganya. IGRP bersifat classfull yang artinya tidak memasukkan subnet mask di tabel routing
Bajaklaut(config)#router IGRP 100
Bajaklaut(config-router)#network 167.205.37.0
Bajaklaut(config-router)#network 167.205.3.0
Bajaklaut#show ip route

OSPF (Open Shortest Path First)
Dapat menghitung jalur routing yang terbebas dari loop, dengan cepat mendeteksi perubahan yang terjadi di jaringan dan menjadikan routing kembali konvergen dalam waktu yang singkat dengan sedikit pertukaran data. Router mengirimkan paket hello ke seluruh jaringan yang terhubung, jika tidak terdengar maka dianggap mati dengan default empat kali pengiriman paket hello.
Pada saat router menjalankan OSPF, router tersebut tidak mengenali router tetangganya. Kemudian router tersebut mengirimkan paket hello ke seluruh interface jaringan untuk memperkenalkan diri. Bila sebuah router menerima paket hello maka router tersebut mengetahui bahwa dia dapat melakukan komunikasi dua arah dengan router pengirim paket hello. Untuk lebih jelas tentang OSPF dapat dibaca di buku TCP/IP standar,desain dan implementasi (kitabnya anak ARC :p)  oleh onno w purbo, adnan, AHT, Fahmi hal.208.
Misal ada 3 router yang terhubung yaitu router siji, loro dan telu. Dimana ip router siji adalah 10.1.1.1/24 dan 72.16.10.1/16, ip router loro adalah 10.1.1.2/24 dan ip router telu adalah 172.16.10.2/16.
Loro – siji – telu

siji(config)#router ospf 100
siji(config-router)#network 172.16.0.0 0.0.255.255 area 0
siji(config-router)#network 10.1.1.0 0.0.0.255 area 0
siji(config-router)#exit


loro(config)#router ospf 100
loro(config-router)#network 10.1.1.0 0.0.0.255 area 0
loro(config-router)#exit

loro(config)#router ospf 100
telu(config-router)#network 172.16.0.0 0.0.255.255 area 0
telu(config-router)#exit

Keterangan:
siji(config)#router ospf ?
<1-65535>               Process ID
siji(config-router)#network ?
a.b.c.d                 Network number
siji(config-router)#network 172.16.0.0 ?
a.b.c.d                 OSPF wild card bits
siji(config-router)#network 172.16.0.0 0.0.255.255 ?
area                    Set the OSPF area ID
siji(config-router)#network 172.16.0.0 0.0.255.255 area ?
<0-4294967295>          OSPF area ID as a decimal value

sementara itu dulu, jangan nanya macem macem. keknya saya juga bakal nggak ngerti heuheuheu

Iklan

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s